Excel для продвинутых: 8 полезных трюков

Excel для продвинутых: 8 полезных трюков

Всем давно знакома программа из офисного пакета под названием Microsoft Excel, но далеко не всем знакомы ее функции, которые на первый взгляд непросто отыскать.

1. Функция ВПР.

Данная опция служит для максимально быстрого нахождения необходимого значения в таблице. Приведем небольшой пример. Допустим нужно определить итоговый балл Бетт, в этом случае мы прописываем: =ВПР(“Beth”,A2:E6,5,0), в данном случае Beth является именем ученика, A2:E6 диапазоном таблицы, 5 - номером столбца, 0 - нежеланием поиска точного соответствия вашему значению.

Функция очень удобна, но имеет определенные особенности. ВПР ищет исключительно слева направо. Чем больше таблица, тем дольше время поиска.

2. Функция ИНДЕКС.

Заключается в отображении значения или ссылки на ячейку в определенном диапазоне ячеек. К примеру, чтобы определить того, кто стал в списке самых успешных продавцов номером 5, нужно ввести следующее: =ИНДЕКС(A3:A11, 5).

3. Функция ПОИСКПОЗ.

Данная функция осуществляет поиск необходимого элемента в определенном диапазоне ячеек, как смежных, так и несмежных. Для максимальной пользы рекомендуется использовать ПОИСКПОЗ вместе с ИНДЕКС, так как лишь вместе они способны заменить функцию ВПР.

Пример. Ищем в большой таблице владельца компании Wells Fargo:

=ИНДЕКС(A3:A11,ПОИСКПОЗ(«Wells Fargo»,B3:B11,0). При помощи ВПР это невыполнимо, так как поиск осуществляется только слева направо.

4. 3D сумма.

У вас возникла нужда определиться с тем, сколько вы тратите денежных средств ежедневно. Во вкладке TOTAL (ИТОГО), необходимо увидеть количество затраченных средств в определенный день. Вводим: =СУММ(‘Week1:Week7’!B2). После данного действия, формула начнет суммировать все значения ячейки B2 во всех активных вкладках. Заполнив все ячейки, мы определим самый затратный день и подобьем все еженедельные расходы в целом.

5. $.

Данный знак является наипростейшим и очень удобным по своему предназначению. Поставьте этот знак и программа сразу прекратит авто корректировку формулы при копировании ее в новую ячейку.

Установка данного знака перед "A" не даст программе повлиять на формулу по горизонтали, а перед "1" по вертикали. Чтобы добиться неизменности ячейки в любом направлении нужно ввести: "$A$1".

6. &.

Данный знак выполняет функцию "СЦЕПИТЬ", что в свою очередь позволяет собираться в одну ячейку все значения. Длительный набор букв заменяется всего лишь этим знаком.

7. Массивы.

Чтобы создать массив или матрицу, необходимо выполнить ряд операций, но они будут существенно сложнее, сравнивая вид работы с обыкновенными формулами.

В виде примера приведем переумножение двух матриц. Воспользуйтесь функцией "МУМНОЖ (Массив 1, Массив 2) и обязательно закройте формулу круглой скобкой. Теперь нажмите сочетание клавиш Ctrl+Shift+Enter, и Excel отобразит вам результаты вашего умножения в матричном виде. Такую же комбинацию клавиш следует использовать при получении результатов, работая с другими функциями на основе массивов.

8. Подборка параметра.

Данная функция является "спасательным кругом" для людей, которые работают в сферах консалтинга или продаж.

К примеру, вы занимаетесь продажей нового кинофильма. Перед вами стоит задача, которая заключается в определении количества экземпляров в третье месяце, которое необходимо для заработка 100 миллионов долларов. Зайдите в меню "Инструменты"-"Подбор параметра". В ячейке Total revenue (Общая выручка) должно оказаться значение в 100 миллионов долларов. Для этого в поле set cell укажите ячейку, в которой будет отображаться финальная сумма, в поле to value (значение) - необходимую сумму, а в by Changing cell (меняя значение ячейки) выберите ту ячейку, в которой будет отображаться проданное кол-во в третьем товарном месяце.

Удачи в работе!

Смотрите также:
Музыка с собой всегда
Когда и сколько...пить воды?

  • 21 Март 2015
  • 8648

Подписаться на обновления HiJi.ru